$re = '/\w+#$/m';
$str = '#78890
_1ASBCJH-
#78890
999
#werer
99999#
today?
999#999
a#dfkjdf#dfd#f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);