re = /\w+#$/m
str = '#78890
_1ASBCJH-
#78890
999
#werer
99999#
today?
999#999
a#dfkjdf#dfd#f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end