using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=partn_key_yr_hr=)(\d{10}|\d{8})(?=\/)";
string input = @"csdasd/asdfadsf/partn_key_yr_hr=20220102/2343243dsfasdf=adsfadsf/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}