re = /(?<=partn_key_yr_hr=)(\d{10}|\d{8})(?=\/)/m
str = 'csdasd/asdfadsf/partn_key_yr_hr=20220102/2343243dsfasdf=adsfadsf/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end