package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(?:\.\d+)?)`)
var str = `Oats 124 0.99 V 1.65`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}