$re = '/(\d+(?:\.\d+)?)/m';
$str = 'Oats 124 0.99 V 1.65';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);