import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(^.*\\/).*";
final String string = "http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00\n\n"
+ "http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00\n\n"
+ "http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00\n\n"
+ "http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}