import re
regex = re.compile(r"(?m)(^.*\/).*")
test_str = ("http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00\n\n"
"http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00\n\n"
"http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00\n\n"
"http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)