package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^ -\/:-@\[-`{-~\t\n\rTZ]+`)
var str = `02/02/2018 22:44 UTC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}