import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^|]*\\|\\s*(\\S+).*";
final String string = "LIVE | 98.183.227.191:24435 | 0.31 | Virginia | 23517 | ip98-183-227-191.hr.hr.cox.net | United States | Blacklist: No | Checked at http://dichvusocks.us\n"
+ "LIVE | 72.167.179.75:60088 | 1.66 | Arizona | 85260 | ip-50-63-58-100.ip.secureserver.net | United States | Blacklist: No | Checked at http://dichvusocks.us\n"
+ "LIVE | 79.127.124.115:1080 | 1.59 | Unknow | Unknow | 79.127.124.115 | Iran, Islamic Republic of | Blacklist: Yes | Checked at http://dichvusocks.us\n"
+ "LIVE | 89.36.166.204:60088 | 1.68 | Cluj | Unknow | vps.ironmedia.ro | Romania | Blacklist: No | Checked at http://dichvusocks.us";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}