import Foundation
let pattern = #"^[^|]*\|\s*(\S+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LIVE | 98.183.227.191:24435 | 0.31 | Virginia | 23517 | ip98-183-227-191.hr.hr.cox.net | United States | Blacklist: No | Checked at http://dichvusocks.us
LIVE | 72.167.179.75:60088 | 1.66 | Arizona | 85260 | ip-50-63-58-100.ip.secureserver.net | United States | Blacklist: No | Checked at http://dichvusocks.us
LIVE | 79.127.124.115:1080 | 1.59 | Unknow | Unknow | 79.127.124.115 | Iran, Islamic Republic of | Blacklist: Yes | Checked at http://dichvusocks.us
LIVE | 89.36.166.204:60088 | 1.68 | Cluj | Unknow | vps.ironmedia.ro | Romania | Blacklist: No | Checked at http://dichvusocks.us
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)