const regex = /(?<=東京)(?<!大阪)特許(?=許可)(?!許諾)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=東京)(?<!大阪)特許(?=許可)(?!許諾)', 'gm')
const str = `東京特許許可局
東京特許許諾
大阪特許許可局
大阪特許許諾`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}