import re
regex = re.compile(r"(?<=東京)(?<!大阪)特許(?=許可)(?!許諾)", flags=re.MULTILINE)
test_str = ("東京特許許可局\n"
"東京特許許諾\n"
"大阪特許許可局\n"
"大阪特許許諾")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")