$re = '/^[0-9]{0,2}-?\.?[1-9]*-?\.?[1-9][1-9][0-9]-?\.?[0-9]*$/';
$str = '212.292.8191';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);