re = /^[0-9]{0,2}-?\.?[1-9]*-?\.?[1-9][1-9][0-9]-?\.?[0-9]*$/
str = '212.292.8191'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end