import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/stb\\/(s\\d{3}\\w?|mag\\d{3})\\/(\\w{5,7}\\-?\\w*)\\/(\\w{4,7}|\\d\\.\\d)\\/tvip\\_firmware\\.(signed.ota.zip|ota.zip|bin|info)(\\?device\\=(s\\d{3}\\w?|mag\\d{3}))?(\\&mac\\=(([A-F0-9]{2}[:]){5}[A-F0-9]{2}))?(\\¤t\\=((\\d{1,2}\\.\\d{1,2}\\.\\d{1,3})|([a-zA-Z0-9-._]{14,60})))?";
final String string = "/stb/s500/linux-qt/dev-MainMenu2017/tvip_firmware.ota.zip?device=s500&mac=10:27:BE:03:B3:37¤t=4.0.23\n"
+ "/stb/s410/linux-qt/beta/tvip_firmware.info?device=s410&mac=11:22:33:44:55:67¤t=4.0.19\n"
+ "/stb/s110/linux/3.9/tvip_firmware.info?device=s410&mac=11:22:33:44:55:67¤t=4.0.19\n"
+ "/stb/s410/linux-qt/beta/tvip_firmware.signed.ota.zip?device=s410&mac=11:22:33:44:55:67¤t=4.0.19&mancheck=true\n"
+ "/stb/s410/linux-qt/beta/tvip_firmware.info\n"
+ "/stb/s412/linux-qt/release/tvip_firmware.ota.zip?device=s412&mac=10:27:BE:05:85:08¤t=4.0.19&background=true\n"
+ "/stb/mag245/linux/release/tvip_firmware.bin?device=s412&mac=10:27:BE:05:85:08¤t=4.0.19&background=true\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}