re = /^\/stb\/(s\d{3}\w?|mag\d{3})\/(\w{5,7}\-?\w*)\/(\w{4,7}|\d\.\d)\/tvip\_firmware\.(signed.ota.zip|ota.zip|bin|info)(\?device\=(s\d{3}\w?|mag\d{3}))?(\&mac\=(([A-F0-9]{2}[:]){5}[A-F0-9]{2}))?(\¤t\=((\d{1,2}\.\d{1,2}\.\d{1,3})|([a-zA-Z0-9-._]{14,60})))?/m
str = '/stb/s500/linux-qt/dev-MainMenu2017/tvip_firmware.ota.zip?device=s500&mac=10:27:BE:03:B3:37¤t=4.0.23
/stb/s410/linux-qt/beta/tvip_firmware.info?device=s410&mac=11:22:33:44:55:67¤t=4.0.19
/stb/s110/linux/3.9/tvip_firmware.info?device=s410&mac=11:22:33:44:55:67¤t=4.0.19
/stb/s410/linux-qt/beta/tvip_firmware.signed.ota.zip?device=s410&mac=11:22:33:44:55:67¤t=4.0.19&mancheck=true
/stb/s410/linux-qt/beta/tvip_firmware.info
/stb/s412/linux-qt/release/tvip_firmware.ota.zip?device=s412&mac=10:27:BE:05:85:08¤t=4.0.19&background=true
/stb/mag245/linux/release/tvip_firmware.bin?device=s412&mac=10:27:BE:05:85:08¤t=4.0.19&background=true
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end