$re = '/^(?!.*car).*report[^/]*\.txt$/m';
$str = '~/home/report_fds.txt
~/car/report_fds.txt
~/home/report_fds.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);