re = /^(?!.*car).*report[^\/]*\.txt$/m
str = '~/home/report_fds.txt
~/car/report_fds.txt
~/home/report_fds.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end