re = /.+?(?=\bthe\b)/
str = 'this is completely customizable through the dashboard. This is a separate area from the main c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end