$re = '/[A-Za-z0-9.]*NSAADS\.[A-Za-z0-9.]*/';
$str = '1.NSAADS.com
NSAADS.1.com
www.microsoft.com
sdfsafdsadf.NSAADS.tw.
blabla.NSAADS.yaddiydda.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);