// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Za-z0-9.]*NSAADS\.[A-Za-z0-9.]*").unwrap();
let string = "1.NSAADS.com
NSAADS.1.com
www.microsoft.com
sdfsafdsadf.NSAADS.tw.
blabla.NSAADS.yaddiydda.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}