const regex = /(.*)\012$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\012$', '')
const str = `some string
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);