use strict;
my $str = 'some string
';
my $regex = qr/(.*)\012$/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";