package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z\d]+(?:\s\|\s[A-Za-z\d]+)+$`)
var str = `Hello | There | Yes
hello|There
456 | 654 | 645 | 465`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}