$re = '/^[A-Za-z\d]+(?:\s\|\s[A-Za-z\d]+)+$/m';
$str = 'Hello | There | Yes
hello|There
456 | 654 | 645 | 465';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);