use strict;
my $str = ' <wp:postmeta>
<wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
';
my $regex = qr/<(wp:postmeta)>\s*<(wp:meta_key)>\s*wpcf-lookbook-front-image\s*<\/\2>\s*<(wp:meta_value)>[\s\S]*?<\/\3>\s*<\/\1>\s*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}