import re
regex = re.compile(r"<(wp:postmeta)>\s*<(wp:meta_key)>\s*wpcf-lookbook-front-image\s*<\/\2>\s*<(wp:meta_value)>[\s\S]*?<\/\3>\s*<\/\1>\s*")
test_str = (" <wp:postmeta>\n"
" <wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>\n"
" <wp:meta_value><![CDATA[]]></wp:meta_value>\n"
" </wp:postmeta>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")