package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`x-\[([^]]+)\]`)
var str = `x-[some test string in here] `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}