$re = '~x-\[([^]]+)\]~';
$str = 'x-[some test string in here] ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);