$re = '/(?<=;)\s+/m';
$str = 'CREATE TABLE TABLE1
( ID INTEGER,
);
CREATE TABLE TABLE2
( ID INTEGER, ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);