re = /(?<=;)\s+/m
str = 'CREATE TABLE TABLE1
( ID INTEGER,
);
CREATE TABLE TABLE2
( ID INTEGER, '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end