#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<![\\])\$\$([^\$]+)\$\$"
Local $sString = "$rac{some}{latex}$$$\int^e_v {en} more$$\$rac{some}{latex}$$$\int^e_v {en} more$$" & @CRLF & _
"$rac{some}{latex}$" & @CRLF & _
"$$\int^e_v {en} more$$" & @CRLF & _
"\$rac{some}{latex}$" & @CRLF & _
"$$\int^e_v {en} more$$"
Local $sSubst = "<div>$$\1$$</div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)