$re = '/(?<![\\\\])\$\$([^\$]+)\$\$/';
$str = '$rac{some}{latex}$$$\\int^e_v {en} more$$\\$rac{some}{latex}$$$\\int^e_v {en} more$$
$rac{some}{latex}$
$$\\int^e_v {en} more$$
\\$rac{some}{latex}$
$$\\int^e_v {en} more$$';
$subst = "<div>$$\1$$</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;