$re = '/\d{4}(?!.+\d{4}.+)/mi';
$str = 'String String 7777 Some more string
String 1234 7777 Some more string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);