re = /\d{4}(?!.+\d{4}.+)/mi
str = 'String String 7777 Some more string
String 1234 7777 Some more string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end