using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]*.?";
string input = @"393. A gypsy caravan passes. They might have interesting items for sale or trade, but
they have touchy tempers and strange customs. They might even want to capture a
PC or pet to sell in the next town.
394. A thief tries to infiltrate the party to steal from them.
395. A fallen tree blocks the road ahead. You notice a path going around it but cannot
see the other side.
396. An nearby tree is infested with animated objects that attack travelers that disturb
their swarm.
3979. A press gang accosts travelers just down the road.
398. A mounted patrol of soldiers ask travellers what they have seen, then pass on the
King's warning to be law-abiding.
399. An otherwise empty stretch of highway, with two rival taverns facing each other
across the road. The publicans try to outdo each other loudly on the discounts and
benefits of their respective establishments to the party. Both seem desperate for
customers. ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}