import re
regex = re.compile(r"[0-9]*.?")
test_str = ("393. A gypsy caravan passes. They might have interesting items for sale or trade, but \n"
"they have touchy tempers and strange customs. They might even want to capture a \n"
"PC or pet to sell in the next town. \n"
"394. A thief tries to infiltrate the party to steal from them. \n"
"395. A fallen tree blocks the road ahead. You notice a path going around it but cannot \n"
"see the other side. \n"
"396. An nearby tree is infested with animated objects that attack travelers that disturb \n"
"their swarm. \n"
"3979. A press gang accosts travelers just down the road. \n"
"398. A mounted patrol of soldiers ask travellers what they have seen, then pass on the \n"
"King's warning to be law-abiding. \n"
"399. An otherwise empty stretch of highway, with two rival taverns facing each other \n"
"across the road. The publicans try to outdo each other loudly on the discounts and \n"
"benefits of their respective establishments to the party. Both seem desperate for \n"
"customers. ")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")