using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""(]*""(?=[^(]*\))";
string input = @"""1"" body ""paragraph"" text (the ""first phrase to capture"" or the ""second phrase to capture""). ""a""
""b"" (""c"",""d"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}