re = /"[^"(]*"(?=[^(]*\))/
str = '"1" body "paragraph" text (the "first phrase to capture" or the "second phrase to capture"). "a"
"b" ("c","d")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end