$re = '/(?:[^>]*?<|>(?:,?\s*|$))/';
$str = 'Rodrigo Demarchi Martins <rodrigo.demartins@hotmail.com>, test test <dema.dido@faculdadefia.edu.br>>, <test>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);