re = /(?:[^>]*?<|>(?:,?\s*|$))/
str = 'Rodrigo Demarchi Martins <rodrigo.demartins@hotmail.com>, test test <dema.dido@faculdadefia.edu.br>>, <test>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end