#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-\s*Título\s*:\s*(.*)\n*-\s*Problema\s*\/\s*Solução\s*:(([^#]+))"
Local $sString = "### Problema/Solução" & @CRLF & _
"" & @CRLF & _
"- Título: Problema de Desempenho no Faturamento de Contratos." & @CRLF & _
"" & @CRLF & _
"- Problema / Solução: " & @CRLF & _
"" & @CRLF & _
"Problema: Toda vez que se faturam muitas notas de uma só vez, demora-se muito e às vezes nem fatura e ocorre um timeout." & @CRLF & _
"" & @CRLF & _
"Solução: O problema acontecia porque o sistema abria apenas uma transação para faturar os 577 contratos, e com isso gerava-se o "JapeSession Timeout". Agora, foi implementado um parâmetro chamado "QTDLOTEFATCONT - Quantidade máx. de lotes no fat. de contrato." com Default = 0." & @CRLF & _
"Regra de exemplo: " & @CRLF & _
"" & @CRLF & _
"param.QTDLOTEFATCONT = 0, o faturamento acontece como antes, e se colocar muitos contratos irá dar o timeout, mesmo se aumentar a quantidade de TransactionTimeOut nos parâmetros do jboss." & @CRLF & _
"" & @CRLF & _
"param.QTDLOTEFATCONT = 100, se a quantidade de contratos for maior que 1, e maior que o informado no parâmetro, será montado um agrupamento de lote, e faturado em partes, Exemplo:" & @CRLF & _
"" & @CRLF & _
"Total de Contratos para faturar = 438 " & @CRLF & _
"param.QTDLOTEFATCONT = 100" & @CRLF & _
"" & @CRLF & _
"- Ao clicar em [Faturar], serão gerados 5 lotes, sendo 4 de 100 notas e 1 de 38 notas." & @CRLF & _
"" & @CRLF & _
"Observação: Se ocorrer algum tipo de erro, e a quantidade já faturada for maior que a do parâmetro, será apresentado na tela apenas o restante para ser faturado, pois os demais já foram faturados e levados para o Portal de Vendas." & @CRLF & _
"" & @CRLF & _
"### Requisitos básicos para atualização" & @CRLF & _
"" & @CRLF & _
"Os arquivos para a atualização estão no site: http://downloads.sankhya.com.br." & @CRLF & _
"O Sankhya-W 3.23 requer base de dados versão 4.21 completa dos scripts do MGE. " & @CRLF & _
"O Sankhya-W 3.24 requer base de dados versão 4.22 completa dos scripts do MGE. " & @CRLF & _
"O Sankhya-W 3.25 requer base de dados versão 4.23 completa dos scripts do MGE. " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"### CONCLUSÃO/COLABORAÇÃO DO Q.A." & @CRLF & _
"" & @CRLF & _
"### Observações complementares" & @CRLF & _
"" & @CRLF & _
"Não tem."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")