// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-\s*Título\s*:\s*(.*)\n*-\s*Problema\s*\/\s*Solução\s*:(([^#]+))").unwrap();
let string = "### Problema/Solução
- Título: Problema de Desempenho no Faturamento de Contratos.
- Problema / Solução:
Problema: Toda vez que se faturam muitas notas de uma só vez, demora-se muito e às vezes nem fatura e ocorre um timeout.
Solução: O problema acontecia porque o sistema abria apenas uma transação para faturar os 577 contratos, e com isso gerava-se o \"JapeSession Timeout\". Agora, foi implementado um parâmetro chamado \"QTDLOTEFATCONT - Quantidade máx. de lotes no fat. de contrato.\" com Default = 0.
Regra de exemplo:
param.QTDLOTEFATCONT = 0, o faturamento acontece como antes, e se colocar muitos contratos irá dar o timeout, mesmo se aumentar a quantidade de TransactionTimeOut nos parâmetros do jboss.
param.QTDLOTEFATCONT = 100, se a quantidade de contratos for maior que 1, e maior que o informado no parâmetro, será montado um agrupamento de lote, e faturado em partes, Exemplo:
Total de Contratos para faturar = 438
param.QTDLOTEFATCONT = 100
- Ao clicar em [Faturar], serão gerados 5 lotes, sendo 4 de 100 notas e 1 de 38 notas.
Observação: Se ocorrer algum tipo de erro, e a quantidade já faturada for maior que a do parâmetro, será apresentado na tela apenas o restante para ser faturado, pois os demais já foram faturados e levados para o Portal de Vendas.
### Requisitos básicos para atualização
Os arquivos para a atualização estão no site: http://downloads.sankhya.com.br.
O Sankhya-W 3.23 requer base de dados versão 4.21 completa dos scripts do MGE.
O Sankhya-W 3.24 requer base de dados versão 4.22 completa dos scripts do MGE.
O Sankhya-W 3.25 requer base de dados versão 4.23 completa dos scripts do MGE.
### CONCLUSÃO/COLABORAÇÃO DO Q.A.
### Observações complementares
Não tem.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}