#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\x19A(\d*)d\[?(\d*)?\]?(.*)-(\S+)\s(\d+)?\:?(\w*)?\s?\d?\x0c?(.*)?\x18|\x19A(\d*)d(\S*)\s?(\d+)?\:?(\w*)?\s?\d?\x18|RECV,4,(\d*),\[?(\d*)?\]?(.*)-(\S+)\s(\d+)?\:?(\w*)?\s?\d?\%?0?C?(.*)?|RECV,4,(\d*),(\S*)\s?(\d+)?\:?(\w*)?\s?\d?"
Local $sString = "A0707288dMessage" & @CRLF & _
"" & @CRLF & _
"A0707288dMessage 1" & @CRLF & _
"" & @CRLF & _
"A0707288dMessage 1:Cancel 1" & @CRLF & _
"" & @CRLF & _
"A0707288dMessage-Location. 3" & @CRLF & _
"" & @CRLF & _
"A0707288dMessage-Location. 3:Cancel 3" & @CRLF & _
"" & @CRLF & _
"A0707288dMessage-Location. 3V1" & @CRLF & _
"" & @CRLF & _
"A0707288dMessage-Location. 3:Cancel 3V1" & @CRLF & _
"" & @CRLF & _
"A0707288d[00]Message-Location. 3" & @CRLF & _
"" & @CRLF & _
"A0707288d[00]Message-Location. 3:Cancel 3" & @CRLF & _
"" & @CRLF & _
"A0707288d[00]Message-Location. 3V1" & @CRLF & _
"" & @CRLF & _
"A0707288d[00]Message-Location. 3:Cancel 3V1" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message 1" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message 1:Cancel 1" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message-Location. 3" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message-Location. 3:Cancel 3" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message-Location. 3%0CV1" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,Message-Location. 3:Cancel 3%0CV1" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,[00]Message-Location. 3" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,[00]Message-Location. 3:Cancel 3" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,[00]Message-Location. 3%0CV1" & @CRLF & _
"" & @CRLF & _
"RECV,4,0707288,[00]Message-Location. 3:Cancel 3%0CV1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")