# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\x19A(\d*)d\[?(\d*)?\]?(.*)-(\S+)\s(\d+)?\:?(\w*)?\s?\d?\x0c?(.*)?\x18|\x19A(\d*)d(\S*)\s?(\d+)?\:?(\w*)?\s?\d?\x18|RECV,4,(\d*),\[?(\d*)?\]?(.*)-(\S+)\s(\d+)?\:?(\w*)?\s?\d?\%?0?C?(.*)?|RECV,4,(\d*),(\S*)\s?(\d+)?\:?(\w*)?\s?\d?"
test_str = ("A0707288dMessage\n\n"
"A0707288dMessage 1\n\n"
"A0707288dMessage 1:Cancel 1\n\n"
"A0707288dMessage-Location. 3\n\n"
"A0707288dMessage-Location. 3:Cancel 3\n\n"
"A0707288dMessage-Location. 3V1\n\n"
"A0707288dMessage-Location. 3:Cancel 3V1\n\n"
"A0707288d[00]Message-Location. 3\n\n"
"A0707288d[00]Message-Location. 3:Cancel 3\n\n"
"A0707288d[00]Message-Location. 3V1\n\n"
"A0707288d[00]Message-Location. 3:Cancel 3V1\n\n"
"RECV,4,0707288,Message\n\n"
"RECV,4,0707288,Message 1\n\n"
"RECV,4,0707288,Message 1:Cancel 1\n\n"
"RECV,4,0707288,Message-Location. 3\n\n"
"RECV,4,0707288,Message-Location. 3:Cancel 3\n\n"
"RECV,4,0707288,Message-Location. 3%0CV1\n\n"
"RECV,4,0707288,Message-Location. 3:Cancel 3%0CV1\n\n"
"RECV,4,0707288,[00]Message-Location. 3\n\n"
"RECV,4,0707288,[00]Message-Location. 3:Cancel 3\n\n"
"RECV,4,0707288,[00]Message-Location. 3%0CV1\n\n"
"RECV,4,0707288,[00]Message-Location. 3:Cancel 3%0CV1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.