$re = '/\W|_\b|\b_/m';
$str = '!_!START_END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);