import re
regex = re.compile(r"\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]")
test_str = ("test\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)