const regex = /\/A\/B\/C\/D\/([^\/]+)\/([^.]+)?(?:\.([^.]+))?\.(?:log|trc)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/A\\\/B\\\/C\\\/D\\\/([^\\\/]+)\\\/([^.]+)?(?:\\.([^.]+))?\\.(?:log|trc)', 'gm')
const str = `/A/B/C/D/TEXT1/TE-XT2.T,EXT3.log
/A/B/C/D/TEXT1/TEXT2.trc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}