re = /\/A\/B\/C\/D\/([^\/]+)\/([^.]+)?(?:\.([^.]+))?\.(?:log|trc)/m
str = '/A/B/C/D/TEXT1/TE-XT2.T,EXT3.log
/A/B/C/D/TEXT1/TEXT2.trc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end